Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through July 10, 2008

Share 
Reply
 
Thread Tools Display Modes
Old     (ryan387)      Join Date: Mar 2004       07-08-2008, 10:19 AM Reply   
we have a 03 supra ssv. So after taking my boat of storage this year i noticed that the steering was incredibly bad. It was as if I was in a car and I had lost power steering. called the dealer and said it could need a new helm. The rudder still has full travel, the wheel is just inredibly hard to turn. My question is 1. what do you think might have happened (it was working fine when we stored it) and 2. If it is dangerous to operate in this condition? I took the boat out and the problem is obviously much worse at lower speeds...The steering assembly is something that I am completely unfamiliar with so any help is greatly appreciated
Old     (02launchssv)      Join Date: Jul 2008       07-08-2008, 10:42 AM Reply   
Could be as simple as the cable (linkage from wheel to rudder). I had mine replaced this year after experiencing the same problem. Dealer told me water wics into cable never to drain and causes the problem. It was relatively simple and inexpensive.
Old     (nauty)      Join Date: Feb 2004       07-08-2008, 11:05 AM Reply   
Most likely cause is the steering cable. In 03 and 04 Skier's Choice got a bad bunch of cables that seemed prone to failure. I had mine replaced under warranty in 06. Then again, steering cables aren't an item that typically lasts the life of your boat. They do need replacing from time to time, so this just could be a maintenance issue.

If it's not the cable the rudder assembly may be bad. I had that replaced as well. In both cases the steering got very stiff and hard to turn.
Old     (elc)      Join Date: Jan 2008       07-08-2008, 1:36 PM Reply   
I had a similar problem. It felt like you described but I could turn the wheel slightly and then it felt like the power steering went out. I thought it was the steering cable etc.

It turned out, a bolt between the dash and steering wheel came loose. The bolt held the parts together that allowed the steering wheel to tilt. the bolt came out about a half inch, that half inch was enough to rub on the top of the housing in the steering column and would not allow the wheel to turn freely.

I have no idea if this is your problem but its such an easy fix you might as well check it out.
Old     (ridininmd)      Join Date: Jun 2006       07-08-2008, 5:09 PM Reply   
Ryan, I replaced the steering cable on my 03 SSV a couple weeks ago. I had the same problems you are having. It will get worse to the point where it takes two hands to turn the boat even at speed. It's a pretty easy fix though.

First disconnect the steering cable from the rudder. You should be able to easily turn the rudder by hand with it disconnected. If you can't the rudder assembly is bad and needs to be replaced. If it does turn easily you need to replace your steering cable.

Take the back seat and v-drive cover out. Then remove the two floor panels, there are screws in the corners. You might need to feel around for them a little the carpet might be covering the screw heads. Then you'll want to pull the front wall of the drivers footwell out. Again the screws will be in the corners. You'll also want to pull the wall out of the rear compartment on the passenger side so you can reach the cable at the rudder.

Once you have all that out it's pretty simple to replace the cable. Disconnect the rack from the back of the helm and pull the old cable out from the front.

Then feed your new one in, there is a hole that it runs down through behind the wall in the foot well that you removed. That runs into a kind of conduit that runs back towards the gas tank. It should be a pretty easy feed. Just have a buddy watch for it to come out the other side and then pull it to the back. Hook it up to the rudder assembly, and to the back of the wheel. Put the floors back in and you're done.

The whole thing took two of us about an hour and a half. I had read that you should tie a string to the old one when you pull it out. But if you pull the floors you don't need to do that. It takes about 5 minutes to get the floors out of there so it's worth pulling them from the start. There is only about a two foot run from the hole in the front under the drivers seat that you won't be able to see the cable. And that part is running through a built in passage so you really can't miss.

Here's the cable you'll need at Ski-Dim
http://www.skidim.com/prodinfo.asp?number=TELSSC13420
I got it cheaper from the factory though, the skiers choice part number is 106285

Good luck, shoot me a email or PM if you have any other questions, but that should pretty much cover you.
Old     (jhgsupra)      Join Date: Mar 2006       07-09-2008, 6:59 AM Reply   
Well done LimoTinted.
Old     (ryan387)      Join Date: Mar 2004       07-09-2008, 12:46 PM Reply   
thanks limotintinted. awesome post. I will fix it. in the mean time, is there any danger of the cable breaking and losing steering? It sounds far fetched but better safe than sorry.
Old     (mogab)      Join Date: Dec 2004       07-09-2008, 3:01 PM Reply   
can you refurb and or lube that cable. My 02 ssv is getting stiff
Old     (jsj)      Join Date: Apr 2006       07-09-2008, 3:16 PM Reply   
They have to be replaced
Old     (ridininmd)      Join Date: Jun 2006       07-09-2008, 3:42 PM Reply   

quote:

can you refurb and or lube that cable. My 02 ssv is getting stiff



Nope, there is a grease fitting on the rudder you can hit though, that might help if it hasn't been done in a while.

Ryan, it probably won't break, but yeah it could. Personally I probably wouldn't skip a night riding waiting for the part but I would get it ordered as soon as possible. Your arms will thank you.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:42 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2019 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us