Wake 101
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Thread Tools Display Modes
Old    HeHateMe (hamkj)      Join Date: Apr 2002       03-04-2015, 3:04 PM Reply   
Long time since I have been here.

I am getting the most annoying LOUD turn on thump!


Sony Head Unit
HSE Revolution Volume Control
Westsounds 420
Zapco Amps.

I think I have narrowed it down to the HSE RVC. What would cause and solve this?

I will do some more trouble shooting. But so far that is where I am at.
Old    Joe Sellhausen (joesell)      Join Date: Apr 2001       03-11-2015, 11:28 PM Reply   
It sucks, but your HSE is shot!

Mine started doing the same thing last year. From what everyone says on here, there's no fix. I got in contact with the guy who ran HSE and he said he's out of the business.

I'd love to hear if anyone came up with a fix. There isn't anything out there that I know of that come close to working like the HSE.
Old    Mikeski (mikeski)      Join Date: Aug 2003       03-11-2015, 11:35 PM Reply   
I had one of the original prototype units and it started doing the same thing after about 6 years of perfect operation. Luckily I was able to get my hands on one of the last production units, it is still running in my boat but it has started reproducing alternator whine. It's not noticeable when we are riding but it is noticeable when we are idling around. I simply rewired my WS420 so it bypassed the HSE when I select Aux input. I toggle between HSE when riding and not when hanging out. Band aid fix but it works. I suppose this approach could also work for you.
Old    Jim Aikins (HSE)      Join Date: Mar 2010       03-12-2015, 12:14 PM Reply   
Sorry to hear the HSE RVC stopped working and I wish we still had the capability to make repairs. It's too bad the overall cost vs. sales etc didn't work out to keep the company alive. So on the same note, what about all the newer boats with this functionality included in the instrumentation, just curious on people's thoughts to the operation?

Jim Aikins
Old    Jason Neves (jv210)      Join Date: Feb 2006       03-12-2015, 5:56 PM Reply   
Jim I've been running your HSE since about 07 or 08 and it is still performing great(knocking on wood, would hate to be without it).

Was in a new Malibu a few months ago with the feature and works great, glad the boat companies are finally putting them on their boats. Only downside I see is having to order a boat with a SH++ty and expensive factory stereo to get this option.
Old    Brian (viking)      Join Date: Sep 2009       03-13-2015, 5:35 AM Reply   
Originally Posted by HSE View Post
It's too bad the overall cost vs. sales etc didn't work out to keep the company alive.

Jim Aikins
It's a bummer! Your product is still extremely sought after even today.
Old    Nikolas Dramountanis (Greeko)      Join Date: May 2013       03-13-2015, 9:42 AM Reply   
I have a lightly used HSE, Used it last season on my last boat... I purchased it early last season from the audio shop in Australia who bought all the remaining stock...

Does anyone want it?
Old    Tim (srock)      Join Date: Mar 2002       03-26-2015, 12:56 PM Reply   
Sounds like my brand new in the box HSE is going up in value. One of these days I will get it installed.
Old    Jonathan Bay (john211)      Join Date: Aug 2008       03-26-2015, 2:29 PM Reply   
^^^ I've got mine velcro'd to a wall in the helm but have never run a wire to it. In baseball card-collecting terms, is that disqualified from 'mint?'
Old    Joe Sellhausen (joesell)      Join Date: Apr 2001       03-28-2015, 5:57 PM Reply   
Jonathan, Let me know if you want to sell it. I'll let you know if it's "mint".
Old    Nicolas Kohler (monkey_butt)      Join Date: Sep 2011       12-15-2016, 9:07 AM Reply   
well - old thread - but I took mine out of the Epic not knowing that the new rig would have SVC standard ... so unit is sitting on my desk ... Anyone still interested in an HSE?
Old    Trevor Petersen (GSXRcrasher)      Join Date: Jul 2013       12-15-2016, 9:40 AM Reply   
I am interested. Ill send a PM.


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

All times are GMT -7. The time now is 2:50 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home


© 2016 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us