Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (simplej)      Join Date: Sep 2011       06-10-2018, 5:05 AM Reply   
Welp, broke something. Axis t22

Boats overheating, cleaned strainers in oil coolers and sea strainer, replaced impeller which was beat but not shredded, pulled and tested thermostat in boiling water which opened (that thermostat housing design SUCKS by the way).

Boat climbs to 210 and holds when idling. As soon as you give it throttle it will climb and alarm. Happened suddenly when wake boarding the other night, no warning, just 20 minutes of riding and bam.


Iím thinking either something is up with thermostats, but it opened in boiling water.
Next step is to check circulator pump and to verify it is not air locked and fill the system with freshwater from there. If that doesnít work we will replace thermostat, anything beyond and we are back to the dealer for warranty repair...


Any other tests I can do at the dock? I really donít want to lose weeks of summer at the dealer if itís something I can fix myself.

Anyone have these problems before?

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:50 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2019 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us