Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old     (calaman)      Join Date: Apr 2007       07-30-2011, 9:25 PM Reply   
Hi All,

Just got back from a short trip on the delta after a long stint in the shop (broken window, swivel racks, recovered the deck, new Arc Amp to replace the zapco,oil change, cording etc). Prior to getting her on the water, I had to reset by trim tab via the dash computer - this fixed the issue i had with the wakeplate not traveling the entire range.....however, the "check engine" text showed on my instrument panel/dash. Oil level fine and drove it all day without issues. I have a feeling resting the wakeplate may require a reset of the "service" panel. Anyone have any input...?
Thanks.....Calaman
Old     (04outback)      Join Date: Jul 2007       07-31-2011, 5:29 AM Reply   
3 complete engine cycles will reset check engine fault if there is no fault remaining.
a cycle is : Crank, bring to operating temp, turn off, allow to cool completely.

Good luck
Old     (gmarkham1)      Join Date: Sep 2003       07-31-2011, 7:15 PM Reply   
I have reset my trim tab gauge before never gave me the issue with the check engine light.

Also, the my 07, takes a lot more than 3 complete engine cycles. I don't know how many I stopped counting. Typically I will check all fluids, oil pressure, and also change the spark plugs, it usually clears up after a few trips out.

Unfortunately the only way to reset the code on the 07 is to take it into the dealer, which sucks, cuz you have to drop the $ to get them to hook up the computer to your boat, but good insurance to make sure its not a larger problem.
Old     (calaman)      Join Date: Apr 2007       08-02-2011, 7:40 AM Reply   
thanks guys for the response. I was hoping it would be something easy but since i have fam coming in for a week from all over the world, I think I'll be taking it in to the shop for a reset so i can focus on fun vs. "is the thing going to break". It's had way too much shop time the last 2 years so going to bite the bullet and tow it around hoping its just a reset. all fluids will be validated (again) as well.
thanks again.
Old     (sunsport22v)      Join Date: Sep 2009       08-04-2011, 9:01 AM Reply   
I had a 2007 Supra Sunsport 22


which I just sold and upgraded to a 2011 Malibu Wakesetter 247 LSV in the past week.


My Supra had the check engine light problem for three YEARs. The problem is that when ever my shop connected their computer, it did not show any faults. The ECM was replaced, the harmonic balancer was replaced, the engine had several turn ups. Nothing fixed the problem. My dealer told me to monitor the water temp and oil pressure, and if that was okay then I was fine. However, I never felt comfortable with that.

Late last season, there was a fix and my check engine light did not come on at all this year. There was a slight problem with the fix. Early this season, one of my exhaust manifold cooling hoses came off, and the raw water (hot) flooded the boat. The engine did go to protection mode, but the check engine light never came on. I had three miles to go and at 5 mph, the bilges not being able to keep up it was stressful.

May of the 2007 Supra’s have the faulty check engine light. If you have a good shop, they will find a resolve for you. My first shop (where I purchased the boat CHICAGO SEA RAY/ ULTIMATE WAKE) was horrible. They wanted to charge me for warranty work and they were the ones that just swapped parts. My new shop worked with Indmar to get my issue resolved – even outside the three year warranty period.

Last edited by sunsport22v; 08-04-2011 at 9:05 AM. Reason: Added images

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:44 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2019 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us