Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through February 10, 2003

Share 
Reply
 
Thread Tools Display Modes
Old     (jwat142)      Join Date: Jan 2002       02-03-2003, 6:58 PM Reply   
I just got two letsgoride sacks in the mail today and the connections are different than the other sack I have. The LGR ones have female openings. The waterbed connectors fit into them, but I don't want them coming out because I have an automatic system where the sacks are always hooked up. The other sack I have actually lets you screw the waterbed connector right on to it. So, what is the best way to connect the LGR sacks to my hose? Thanks.
Old     (jwat142)      Join Date: Jan 2002       02-04-2003, 4:53 AM Reply   
Anybody have any ideas?
Old    chris_hargis            02-04-2003, 6:11 AM Reply   
In the interim until you figure out something permanent, can you use wire ties to hold it on?
Old     (typhoon)      Join Date: Jul 2001       02-04-2003, 6:19 AM Reply   
I have the same connections. Go to the irrigation department and get a npt threaded on one side and a hose barb on the other. The best permanent attatchment.
Old     (typhoon)      Join Date: Jul 2001       02-04-2003, 6:20 AM Reply   
you can also use the flow-rite if you need a quick release.
Old     (jwat142)      Join Date: Jan 2002       02-04-2003, 6:29 AM Reply   
Ty,
Does the sack drain alright having a connection like that since it doesn't have anything actually going down into the sack?
Old    jmccallum            02-04-2003, 6:45 AM Reply   
Mine drains pretty good! Not perfect, but I gave up caring... lol

Also If you use a self-primer it doesn't matter!
Old     (jwat142)      Join Date: Jan 2002       02-04-2003, 6:51 AM Reply   
I guess it won't matter then, because I have a self priming pump. Thanks!

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:00 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2019 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us