Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through July 21, 2006

Share 
Reply
 
Thread Tools Display Modes
Old     (malibuboarder75)      Join Date: Jan 2004       06-30-2006, 4:59 PM Reply   
Ok, we finally fixed the engine 2 weeks ago. But we were still having charging problems. We took off the alternator and guess what, both bolts were broken inside of the engine block. The same alternator our mechanic installed. We drilled out the bolts then pulled them out of the block. We also noticed one of the wires wasn't hooked up. This must be the shady work of our mechanic. Now our boat finally charges and gets a good reading. Maybe most of our problems were our mechanic and not the boat. Should we report our mechanic to malibu? Not that we are ever going to use him again.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 8:12 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2016 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us