Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through September 10, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    Jay (jayc)      Join Date: Sep 2002       09-03-2007, 8:36 AM Reply   
The alternator has died on my PCM'd mastercraft. A friend has given me a mercruiser 55A alternator which the output will be fine for my needs as I have no accessories other than a bilge and blower (this is my retro ski boat not my pimped wake boat).

Any how the alternator i removed just had a battery post and a green wire going to +12V switched by the ignition.

New alternator has EXC post and a S post. I think EXC is the exciter which needs +12V switched by the ignition? The S post is maybe the sensor for the regulator so needs to go to as close to the positive terminal as possible?

Am I right guys or is it going to go pop?
Old    Steve Oh (olskooltige)      Join Date: Mar 2007       09-04-2007, 7:46 AM Reply   
The exc needs to be connected to 12+. It is the sense wire that tells the alt to charge (excitor). The S could also be an output to a dash light or tach pickup. You can most likely leave it disconnected if that is the case.

How old is the alt? The regulator should be internal.

(Message edited by olskooltige on September 04, 2007)
Old    Jay (jayc)      Join Date: Sep 2002       09-04-2007, 8:41 AM Reply   
The alternator is around 98. Well thats the year boat it came off.

From googling it seems S is the sense terminal and should go directly to the battery + (or a close to as possible) as it detects the voltage and changes charge accordingly. Most websites seem to say that if its not connected its no problem and the internal regulator will keep the voltage at 14.4V anyhow.

I'll just do the bat+ and exc for now and see how that goes.
Old    Steve Oh (olskooltige)      Join Date: Mar 2007       09-04-2007, 11:27 AM Reply   
I would think exc would mean it's the excite terminal, but it could be a sense terminal.....
Old    Jay (jayc)      Join Date: Sep 2002       09-04-2007, 12:19 PM Reply   
With +12v wired on the exc terminal it outputs 15V according to my digital multimeter. The same with the S terminal wired direct to the battery.

This is with a fully charged battery and no load so is that OK or too high?
Old    Steve Oh (olskooltige)      Join Date: Mar 2007       09-04-2007, 1:14 PM Reply   
14.4 is normal, 15 is acceptable, so it is charging. If you turn on something, like a blower, it should droop. What happens if you bump the RPMs? It shouldn't go over 15.5-16.

(Message edited by olskooltige on September 04, 2007)
Old    Jay (jayc)      Join Date: Sep 2002       09-04-2007, 1:21 PM Reply   
Doesn't go over 15.4 with high rpms. Noticed it won't start charging until revs go over 1500 (battery light is on). Once over this it goes up to 15V and will drop down to 14V at idle (battery light off).

I'll try it tomorrow and stick the blower on as that draws a good few amps. Just don't want to over cook the battery.
Old    Steve Oh (olskooltige)      Join Date: Mar 2007       09-05-2007, 7:26 AM Reply   
You can try a smaller pulley to help out the low RPM charge. You should have 13.5+ at 800RPM. 15.4 at high RPM is perfect. If you need more alt help you can get in touch with Ron at dbelectrical.com. If that one ends up not being usable, he can get a you a marine HO (>160A) in a delco case (mounts to most gm blocks) for under $200. He has other ratings as well for even less. Their warranty cannot be touched.
Old    Jay (jayc)      Join Date: Sep 2002       09-05-2007, 12:31 PM Reply   
Cheers for the help. A 160A alternator might be overkill for a boat with only a bilge and blower! :-)
Old    Adam Curtis (acurtis_ttu)      Join Date: May 2004       09-05-2007, 12:43 PM Reply   
I have tried those HO alt's for under $200, I have had terrible luck with them ( went through 3 in less than a year) . when my local alt guy tore one apart he said they were made using "cheaper" parts. He said unless I was looking to spend closer to $400, stick with the 105 amp alts for longevity. Good thing ws they were all warrantied, but having them go out all the time wasnt' worth it.
Old    Steve Oh (olskooltige)      Join Date: Mar 2007       09-05-2007, 12:49 PM Reply   
You tried an HO alt from dbelectrical.com, or a generic one? The alts from DB are not generic chinese alts. They are hand wound/assembled built when you order usually.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:26 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us