Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through June 17, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    steve cox (steve300ex)      Join Date: Feb 2007       05-28-2007, 5:38 PM Reply   
took the avalanche out wake surfing for the 1st time. stock 3 ballasts , starboard side empty. about 150 lbs of lead on the port. and two people on port side.couldn't seem to get the rope slack at all. tried from 8.5 to 11.5 on the pp. Do i need more weight to catch the wave? or maybe im in the wrong position?about how far away from the platform should i be. will it be obvious and happen or do i have to pump to keep up? im workin on gettin the pics up.
Old    Steven Soeka (premier136)      Join Date: Jul 2006       05-28-2007, 6:03 PM Reply   
post in the wakesurfing section for a better response
Old    Craig (yosquire)      Join Date: Jun 2005       05-28-2007, 7:40 PM Reply   
fill up your mid-ship ballast, add a 450lbs sack in the port skilocker, a 450lbs sack on the floor. Keep moving people around until the wakeshapes..

And yeah, ask on the wake surf forum. Not all of them make it over to this forum and they really know their stuff.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:05 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us