Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through May 25, 2007

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (hype29)      Join Date: Feb 2007       05-12-2007, 1:37 PM Reply   
today I just got to the lake I was in idle waiting for my wife to park the truck. As soon a I went to go her it felt as if my prop fell off. It would not go at all. So I had to get a tow in. Put it on the trailer and when I got it out the prop was up against the rudder. Luckly there was no damage to either of them. It seemed as if the whole driveshaft was disconnected. I pushed it back in to where it should be and found that the nut on the back side on the trany coupler was completly off. So I Put loctite on it and tightned as good as I could. Do you guys think that is all I need to do? That looked like the only problem. Has any one else had this happen to them? Seems like it could do some pretty hefty damage if you were going fast. thanks

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:00 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us