Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through May 25, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    Robbie Hamilton (gandr_nautique)      Join Date: Feb 2006       05-01-2007, 11:55 PM Reply   
We bought Rubicon 450's at the end of last year for our boat in Ireland and after spending $1600 on them and having them shipped all the way home we were expecting them to be unbreakable. The sound is great but on our first outing we nearly lost one of the grills on the centre speaker which popped off and landed in the boat. Also the speakers on both sides are coming loose and are starting to move around. I have emailed both Skylon and the company i bought the speakers from and have heard nothing back as of yet. Granted if was two days ago but when i spend that amount on a pair of speaker i dont expect them to fall apart. Also when i recieved the speakers there was no instructions with them. Nothing to tell us what was the best way to hook them up no specification. I would like to know has anyone had similar problems with there's as we spent alot of time and money trying to decided on the best brand for the job.
Old    Buzz (buzz_grande)      Join Date: Mar 2004       05-02-2007, 1:07 AM Reply   
I have had mine for probably almost a year, and have had NO problems with them at all. They are very sturdy, rock-solid, etc. I have probably over 100 hours on the water with them, towed across the state, etc. Skylon or your dealer should take care of you. I am very happy with my 450's. Best of luck!
Old    Sam (wake1823)      Join Date: Dec 2005       05-02-2007, 5:40 AM Reply   
I don't knwo where you bought them from but having somthign liek that shipped internationally may be a large reason why it's in the condition it's in.....god only knwos how that package wastreated all the way over there.
Old    Robbie Hamilton (gandr_nautique)      Join Date: Feb 2006       05-02-2007, 5:50 AM Reply   
There was nothing wrong with the speakers at all when they arrived it was just after the first day they have come loose. Am still waiting to hear back from Skylon about the problem. Hope someone contact me today.
Old    Steve Oh (olskooltige)      Join Date: Mar 2007       05-02-2007, 6:38 AM Reply   
Call me crazy, but couldn't you just tighten them up? Seems like a simple fix.
Old    Diggs (pdxWAKE) (tyler97217)      Join Date: Aug 2004       05-02-2007, 6:49 AM Reply   
I had a set last year that the grill was loose on one of the speakers... easy fix and nothing to complain about. If your speakers are loose on the tower; did you use the rubber grommets that fit between the tower and the clamp. They give you a whole box of them. There is no reason you should get any speaker movement. Tighten them. I have owned 2 pairs of Rubicon 450's and have been happy. I have heard a few negative things on Customer Support though. I have had no problems though. Good luck. Give them a call. They have answered any of my phone calls.
Old    Robbie Hamilton (gandr_nautique)      Join Date: Feb 2006       05-02-2007, 6:57 AM Reply   
You arnt crazy. We ended up taking them apart to get at the allen key nuts that are inside the speakers. We tightened them as much as possible but they still are loose. Its not the clamps it the actual connection between the speaker housings. They sound great and from that point of view we are very happy it just the fact nobody has been on to us and that we would like to get a third set of clamps as this would stop any further movement for sure.
Old    Diggs (pdxWAKE) (tyler97217)      Join Date: Aug 2004       05-02-2007, 7:00 AM Reply   
Have you tried calling them 1-951-940-9999
Old    Craig (yosquire)      Join Date: Jun 2005       05-02-2007, 1:55 PM Reply   
916-991-1106 takes you directly to Skylon in Sacramento. Ask for Dave, he is the one who engineered them.

I had the problem with the "bridge" piece loosening up. While at Skylon on warranty they "machined a new bridge" for them. I haven't actually taken them out of the box to inspect them yet. I've also had the problem of them loosening up between the clamp and the speaker. At first I thought I just didn't tighten it very well, then I realized that it wasn't me the second time.

> Call me crazy, but couldn't you just tighten them up? Seems like a simple fix.

You are crazy. It's a lot of work.
Old    266CrownlineBR (266crownlinebr)      Join Date: Apr 2007       05-05-2007, 7:01 PM Reply   
Mine came with the wrong size clamps from Wakesides recommendation. They were cool about it though and sent me the smaller ones. Then when I opened the second box, I found that the HLCD metal cap was missing. I e-mailed Skylon on Monday and they said that they would send them out to me free of charge. They have been in a box since November, so I thought it was cool of them to do for me in May.
Upload
Old    Randy (dudeman)      Join Date: Mar 2005       05-06-2007, 6:48 AM Reply   
One side of my 350's was loose when I got them. Took a while to get in touch with Skylon and they said if I took them apart to tighten the bridge, they would void the warranty. While clamped on the tower the speakers were rock solid but after a few outings, both bridges were loose. It's mostly a cosmetic thing, but for that kind of money, it shouldn't happen. I feel your pain.
Old    Hate N Pain (hatepain)      Join Date: Aug 2006       05-06-2007, 11:02 AM Reply   
A little OT so i'm sorry but do you have to run multiple sets of speaker wire up to your speakers on those or is it just one set?
Old    266CrownlineBR (266crownlinebr)      Join Date: Apr 2007       05-06-2007, 5:40 PM Reply   
Two sets for me.
Old    Robbie Hamilton (gandr_nautique)      Join Date: Feb 2006       05-09-2007, 12:00 AM Reply   
So i rang Skylon early last week and spoke with a guy who said he would sort it out and email me back by the end of the day. I still havent heard back from them. When i spoke with him asking him had he received my email which i had sent a few day previous he said that they only check there emails about once a week. Not very professional if you ask me. I have to get a picture over to the guys who supplied the speakers to me to see what action will be taken. All i am really looking for is two more sets of bracket to avoid any further movement. Hopefully they will come through before the summer is over.
Old    Nu Bu (05mobiuslsv)      Join Date: Apr 2006       05-09-2007, 7:51 AM Reply   
I had to send one of 150's back because the tweet blew. They fixed it, answered e-mails along the way, and shipped it back. I'd try to call Paul at the number in their main website.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:11 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us