Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through May 25, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    KennyMo (boardcrazy)      Join Date: Oct 2003       05-06-2007, 10:31 PM Reply   
I am going to upgrade my X-Star with the Fly High Sacs and wanted to know if I should plumb it in, or get separate ballast pumps for them.

I have read a lot of good feedback on the Fly High Sacs and have also read a lot about having them plumbed into the existing system. I am just concerned that it will take a ton of time to fill all the sacs up and thought I should just install more pumps for the upgrade.

Any comments welcome...has anyone installed the fly highs with additional pumps...how long does it take to fill when they are just plumbed in.

Thanks for any help.
Old    Ryan B. (rrbooker)      Join Date: Feb 2003       05-07-2007, 7:41 AM Reply   
I have the same system on my boat. I had it plumbed into the existing system and it works great It takes about 10 to 15 mins to fill factory and the 2500lbs in sacs! I wouldn't waste my money on more pumps. Its just one more thing you have to worry about.
Old    WAlove (masonwakerider)      Join Date: May 2003       05-07-2007, 10:32 AM Reply   
When it comes to adding ballast and pumps, its time vs money. Spend more money on pumps to spend less time filling and draining. Whats more important to you. Ballast puppies are about 10 gal. per min. How many gallons are you adding. (IIRC the fly high x-star package is a little more then what is stock, so figure a little more then twice the time.)
Old    KennyMo (boardcrazy)      Join Date: Oct 2003       05-07-2007, 8:19 PM Reply   
If it olny takes 10-15 minutes then I don't see a need for any more pumps. Do you think I need just the sacs or should I get the whole kit?

It seems like $600 is a lot for a maifold, hoses and valves. But I don't know where to get everything.

What are your experiences???
Old    Ryan B. (rrbooker)      Join Date: Feb 2003       05-08-2007, 7:59 AM Reply   
I bought the whole kit, but the place i bought my boat gave it to me for a great deal! did you buy your boat from a dealer? If so contact your sales man, he should be able to hook you up!
Old    Andy Larson (mwmc_andy)      Join Date: Dec 2005       05-08-2007, 12:53 PM Reply   
Is the boat a 2007? FYI, there is a bit of an issue adding the BI kit to 2007's. You can only reporgram the pumps to run for 5:30 seconds. MC is working on new electronics for the ballast system that will allow you to program the system to run longer. Right now if you want to fill the BI system on a 2007 you have to fill it as far as 5:30 will go and then keep flipping the switch to run an extra 20 seconds. The other solution is wiring the pumps so that they are only controlled by the switch and will not time out. MC hopes to have new relays out that will allow the longer run time in about a month. Until then wiring around the relay is probably the best answer. Good Luck.
Old    Greg Holloway (holloway0105)      Join Date: May 2007       05-08-2007, 2:36 PM Reply   
So are you saying even if you flip the switch off and back on that it will not run for an additional 5:30 sec.?
Old    Spencer Welch (spencerwakeside)      Join Date: Sep 2005       05-08-2007, 3:40 PM Reply   
I thought Chris at Fly High had instructions on how to reprogram the system to turn the timer off. Maybe it was only for the 5:30. That sucks.
Old    KennyMo (boardcrazy)      Join Date: Oct 2003       05-08-2007, 11:42 PM Reply   
Mine is a 2006 so I shouldn't have a problem with that. I am going to put a call into Chris in the next couple of days to see if he can give me some advice.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:29 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us