Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Wakeboarding Discussion Archives > Archive through May 13, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    Greg Bodor (gti2lo)      Join Date: Nov 2005       04-22-2007, 7:31 PM Reply   
Up here in the Muskoka, the weather has been odd just like everywhere else in the mid west and east coast.

Just last weekend there was ice on the water.
Upload

This week totally different story.

Sunny, warm about 73 degrees... water temp was 49 on saturday.. but on sunday it hit 52 degrees.. so it was time to put on the wetsuit and hope for the best.

Felt nice to go out.. had one thing on my mind... "Don't fall!!"

No ballast in the boat and 2 people.. made a quick ride.. nieghbors thought I was "crazy", "nuts", "wacko"

meh... what I say.

Upload
Upload
Upload
Upload
Old    Blair (twitch)      Join Date: Dec 2004       04-22-2007, 8:36 PM Reply   
nice... i cant wait for the ice to break around here... its come off the sloughs... just gotta wait for the lakes now...
Old    Luke B (pureblue)      Join Date: Jun 2002       04-22-2007, 9:08 PM Reply   
So how was the temp with the wetsuit on? And what kind of suit do you have? I am shopping around for one and wanted to see other peoples thoughts.
Old    Greg Bodor (gti2lo)      Join Date: Nov 2005       04-23-2007, 6:47 AM Reply   
Temp was fine with the suit on... hands and feet were the only things cold in the water....

It's a 3/2mm Jet Pilot suit.. sealed seems and "firefur"

Really nice suit...
Old    alan plotz (alanp)      Join Date: Apr 2001       04-23-2007, 10:13 AM Reply   
greg- one thing i noticed in your photo is youre sucking in your knees. stand tall at the top and extend you knees.
i too think youre crazy for getting in water that cold.
Old    Greg Bodor (gti2lo)      Join Date: Nov 2005       04-23-2007, 10:32 AM Reply   
Yes... I know... only picture I got... (thanks..)

was tired at that point.... was already ridin for 10 mins or so..

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:19 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us