Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through April 09, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    Bill Montanye (bill)      Join Date: Feb 2001       03-11-2007, 9:50 AM Reply   
I have a 2000 supra launch and while i have have very few issues over the years and like my supra a lot, i am having this reoccuring issue with the MDC sending unit that controls the guages and speedo pickups etc..

Its basically the brain of the dash and has the water pick up running in the back of it and converts that into the digital speed plus runs the other critical guages ..

I have had that part replaced 4 times in 7 years..the first three were under warranty but the last wasnt and now it went out again..

It called a medallion brand mdc1600 sending unit..

i am going to pull this one apart and look at the internal parts to see what actually happened..my guess is the part of the unit seperating the water from the circuit board is cracking and then letting water get into the board and shorting out..

this happens every 18 months and maybe its the cold and it freezes and cracks but i am in Texas and use the boat during the winter without issue until it breaks..

I feel its a bad design and an issue that was resolved as Skiers choice upgraded this sytem in the 2001 with stacked circuitry and a paddle wheel.

So before i replace it has anybody else had this happen more then once or at all to their Supra/Moomba older then 2000?

I also wonder IF supra can help me with this and i will contact them to see if this time how hard would it be to upgrade to the newer harness,boards and paddle wheel and maybe help me with the cost of this since its happened now 4 times in 7 years and seems to be a flaw in the system..

this is getting frustrating and expensive..

any help or suggestions would be appreciated

tia

bill
Old    Bill Montanye (bill)      Join Date: Feb 2001       03-12-2007, 9:15 AM Reply   
bump,anybody??
Old    Bill Montanye (bill)      Join Date: Feb 2001       03-13-2007, 8:01 PM Reply   
??/??
Old    footer blood (jblood98)      Join Date: Apr 2007       04-04-2007, 6:24 PM Reply   
Bill,

I just had this happen in my 2001 Sanger DX2. I think it froze and water entered the case at the pressure sensors. It is not very well protected.

I took mine apart to see if I could repair but it is very difficult to get the board out. It isnt really designed to be serviced.
How much did the replacement unit cost you? Where did you get it?
Old    Jay (jayc)      Join Date: Sep 2002       04-05-2007, 1:28 AM Reply   
I'd just bin it and run a convential pitot speedo and PP.
Old    Jeff Burnside (outbackls)      Join Date: May 2004       04-05-2007, 6:45 AM Reply   
Bill,
Check the Supra and Moomba forum pages. I know the older Moomba boats had that same problem. Do a search on both and I'm sure you will find plenty of info.

www.moomba.com

www.supraboats.com

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 8:21 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us