Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through April 09, 2007

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (mossy44)      Join Date: Oct 2001       04-03-2007, 3:01 PM Reply   
I need some help. I have 3 amps, my engine, and an isolator hooked up to 2 batteries. I am not educated enough to know how to "dewinterize" my boat and hook back up the wires to the batteries. I thought i knew until this past weekend i made some nice sparks and i HOPE i only blew a fuse.

i was able to hook the boat up to run it and make sure the engine ran. however, my amps wouldnt turn on. so, i left the 2nd battery without anything hooked to it and ran the boat. the stereo turns on, but none of the amps, which is why i think i blew a fuse in the inline fuse.

my question is, is there some basics on what is connected to the positive and the negative? or is this too complicated and it has to be specific for anyone to tell me answers. i might have to tow the boat home and get some help if so.

for example, ground wires, power wires, a wire running back toward my engine or isolator (not sure which), etc.

i hope that all made sense.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 2:20 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us