Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through April 09, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    gary harvin (gharvin)      Join Date: Oct 2005       03-21-2007, 7:56 AM Reply   
excuse my ignorance but i had my boat winterized this past fall, do i need it to be de winterized or is this something i can do myself? also after winterazation i had no power whatsoever in the boat, what the hell do i re-connect to get power back in?
Old    Mallenger (mallenger)      Join Date: Jun 2006       03-21-2007, 8:14 AM Reply   
If your boat was winterized the same way that i winterize mine, all you have to do is put it in the water and start it up. I just take the main water intake loose, but it in a 5 gallon bucket of marine fresh antifreeze, run the motor till antifreeze starts coming out and then shut it down. This fills the motor with antifreeze instead of freezable water.
Your battery is probably unhooked, hence no power. Either that or the battery wasn't unhooked over the winter and it went completely dead.
Old    Nacho (denverd1)      Join Date: May 2004       03-21-2007, 8:16 AM Reply   
some shops will pull the battery. or disconnect it for sure. find your batt and make sure its there and hooked up.
Old    gary harvin (gharvin)      Join Date: Oct 2005       03-21-2007, 8:22 AM Reply   
i checked the battery connections the other weekend everything looked to be in tact, i was thinking maybe a primary switch near the perko for the dual batts. thanks for the help.
Old    Face Planter (mastercraft1995)      Join Date: Nov 2002       03-21-2007, 8:33 AM Reply   
Has the battery been on a trickle charger this winter? If not you have a dead battery.
Old    matt moss (mossy44)      Join Date: Oct 2001       03-21-2007, 5:02 PM Reply   
make sure that all of the hoses are connected in the engine. i dont know the specifics, but i do no that my shop disconnects the water hose and a few other things and you need to make sure they are all in tact.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:49 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us