Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through December 20, 2006

Share 
Reply
 
Thread Tools Display Modes
Old    Moki (moki)      Join Date: Nov 2006       11-28-2006, 10:36 PM Reply   
I just replaced my vintage Tige tower with a new Xplosion tower and added the Wetsounds Pro 485s. I am stoked to get the boat back. It is in California right now getting its extreme makeover. Too bad that I have 5 inches of snow in my yard and won't be able to try it on the water until next spring.
Old    Moki (moki)      Join Date: Nov 2006       11-28-2006, 10:37 PM Reply   
PicsUpload
Old    Moki (moki)      Join Date: Nov 2006       11-28-2006, 10:38 PM Reply   
Pic 2Upload
Old    Moki (moki)      Join Date: Nov 2006       11-28-2006, 10:39 PM Reply   
pic 3Upload
Old    Anodyne (anodyne)      Join Date: Feb 2006       11-28-2006, 10:53 PM Reply   
who makes the Xplosion tower??
Old    Greg (greg_sa)      Join Date: Jan 2006       11-28-2006, 11:10 PM Reply   
The tower matches the boat very well!

What year is your Tige?
Old    Moki (moki)      Join Date: Nov 2006       11-28-2006, 11:16 PM Reply   
They are new on the market, based out of
Southern California. Their website is still under construction but it is http://xplosiontower.com. Great guys and an awesome product.
Old    Moki (moki)      Join Date: Nov 2006       11-28-2006, 11:18 PM Reply   
Thanks Greg, it is a 2000, I picked it up this year with only 100 hours on the engine.}

(Message edited by moki on November 28, 2006)
Old    Nate (norcalmalibu)      Join Date: Jun 2004       11-28-2006, 11:45 PM Reply   
that tower fits your boat perfectly, but im not a fan how it curves on the top.
Old    Lucky275 (lcky275)      Join Date: Jul 2002       11-29-2006, 5:22 AM Reply   
That's a perfect fit. Are you going for the 10' bimini, as well?
Old    Moki (moki)      Join Date: Nov 2006       11-29-2006, 9:44 AM Reply   
Lucky275,
Yes,I am going for the 10' bimini. I am going to have the standard bimini and then an extension that can be zipped on.
Old    David (tparider)      Join Date: Aug 2003       11-29-2006, 10:27 AM Reply   
You're going to love those Wet Sounds! Nice tower too!
Old    Big D (bigdtx)      Join Date: Feb 2005       11-29-2006, 10:31 AM Reply   
The swim platform on that site looks pretty cool too.
Old    Moki (moki)      Join Date: Nov 2006       11-29-2006, 1:40 PM Reply   
Thanks guys, next steps are hooking up the amps and upgrading my batteries and electrical.
Old    JTW (sangerlover)      Join Date: Sep 2005       11-29-2006, 2:55 PM Reply   
What amp are you feeding them with?
Old    Fro-Z (froese)      Join Date: Jun 2005       11-29-2006, 4:00 PM Reply   
I'm curious about what amp(s) you're using too. I'm also not a big fan of the curve one the top bar, but the lines of the tower are sweet. That curve, and the way it angles the pro485's out, ought to distribute sound at a nice, wide spread... bring the ear plugs!
Old    Mikeski (mikeski)      Join Date: Aug 2003       11-29-2006, 4:32 PM Reply   
JTW and all,

Now that I have over 100 hours on my WetSounds Pro-485s and amps I don't mind making a recommendation. These speakers respond extremely well to power. Unfortunately big class A/B power draws heavily on our electrical systems. Class D power does not provide clean enough power, unless it has a another processor to clean things up. I have been using Tripath amplifiers for a couple years now.

I have had very good luck with this amp on my Pro-485s:
http://www.woofersetc.com/index.cfm?fuseaction=product.display&product_id=12 0

It is probably the most cost effective, power efficient readily available to power the WetSounds.

Other good options include the Arc digital amplifiers, if you want to spend a few more $$.
Old    Jon Allen (jon_a)      Join Date: Feb 2003       11-29-2006, 4:43 PM Reply   
Looks good. Wetsounds are definitely the speakers to have right now. So clear and so loud!
Old    Moki (moki)      Join Date: Nov 2006       12-03-2006, 11:57 AM Reply   
Hey guys, sorry for the delay in the response, I have been out of town for a few days. I am using the Eclipse XA4000. It is a Class D amplifier, so it does not draw a lot of power, but it is using the Ice Power chip. This new technology gives you full clean sound without the current draw. Here is a link that explains more:

http://www.icepower.bang-olufsen.com/sw1773.asp

Here is the amp that I am driving it with:
http://www.eclipse-web.com/amp/xa4000.html

Unfortunately, I do not have the amps hooked up yet, so I cannot at this time tell you how well the amp really performs.
Old    Moki (moki)      Join Date: Nov 2006       12-03-2006, 9:20 PM Reply   
Mikeski,
You are definitely a wetsounds veteran. Any other tips you can give me on maintenance, lessons learned, etc.

Thanks in advance
Old     (will5150)      Join Date: Oct 2002       12-04-2006, 9:22 AM Reply   
Moki- did the tower go right into the same mounts as the old Metcraft or did you need to do some gel coat work?
Old    Moki (moki)      Join Date: Nov 2006       12-04-2006, 11:18 AM Reply   
Will,
The tower went into the same mounts in the front, but I had to fill in the back 2 holes and re-drill. I was expecting all four holes to be filled, but was pleasantly surprised with only 2.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 9:04 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us