Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through July 21, 2006

Share 
Reply
 
Thread Tools Display Modes
Old    Ron (rcsanger06)      Join Date: Sep 2005       07-12-2006, 12:54 PM Reply   
Hello all,
Well Had my boat for about 9 months now approx, Bought it at the end of the last season took it out for a hour to hour in a half and now she overheats ( no water to the engine ) turns out the Sea pump isnt working, Took it back to the dealer and sure enough the sea pump was bad, they Claim the propeller was burnt up causing it to not work, and its will be 129.00 and to pick my boat up asap, because the lack of room at the service center. Still under warrenty / also extended warrenty and nothing will cover this. The funny thing is with a 1 hour on the boat (first trip to castaic to test it out)at 3000 rpm the warning buzzer sounds, They Claim it was over heating, when plugged in the scanner. So basically it was doing this right off the sales floor. I feel I got screwed with this whole thing. Question I have is what would cause the unit to burn up, expecially that fast..
Thanks
Ron
Old    E.J. (deuce)      Join Date: Mar 2002       07-12-2006, 1:05 PM Reply   
You have only used your boat for 2 hours in 9 months......... Jeeze....you need to get your priorities straight.

Problems happen with boats, it is the nature of the business. As long as the dealer takes care of the issue, does this with a smile and in a timely fashion.....and it is covered under warranty....all is well.

Again, no boat is perfect, this stuff happens...even after a few hours. Nothing is perfect....and no manufacturer is immune to having this sort of issue.
Old    bocephus            07-12-2006, 1:09 PM Reply   
Call Scott Pellaton! He will take care of it! Problem Solved. He's the Head Customer Service guy for Sanger.
Old    JTW (sangerlover)      Join Date: Sep 2005       07-12-2006, 1:12 PM Reply   
The intake grate could have been clogged with debris starving everything else downstream of its cooling.

Have you started your boat dry without water for any length of time which would fry your impeller very quickly?
Old     (bensk8in)      Join Date: Feb 2006       07-12-2006, 1:15 PM Reply   
They're screwing you man, the merc motor has a 1 year warranty from the factory, under my knowledge the sanger has a 3 year warranty. Your impeller (radiator for a boat, not the propeller) should be covered for atleast 1 year.
Where did you get the boat? The boating industry needs a little 101 on customer service. Mercruiser motors, sorry to say are assembled as "efficiently" as possible dollars wise. Sounds like a defective impeller.
Old    C.I.E..... Evan (guido)      Join Date: Jul 2002       07-12-2006, 1:27 PM Reply   
You never know.... It could have been started dry at some point too. An impeller will burn up within moments if started dry. I still can't believe how many people I see fire their boats up on the way out of the water.

Truth be told though I'd be very disappointed if I was treated this way by my dealer. I'd definitely get ahold of Scott Pelaton and let him know what's going on. That should be a no brainer to get taken care of, even if it was your fault. Customer goodwill if nothing else.
Old    Big Ed (big_ed_x2)      Join Date: Jul 2004       07-12-2006, 1:33 PM Reply   
My dealer said that coming out of the water is not bad but starting it before you get in the water is a killer.No water in the engine at all compared to some from circulation of the boat running prior.Not that is advisable to do either.
Old    bocephus            07-12-2006, 1:55 PM Reply   
Scott Pellaton is on the boards here!

spellaton@sbcglobal.net

He's the sales director not customer service.
Old    Ken (ghostrider_2)      Join Date: Aug 2004       07-12-2006, 2:12 PM Reply   
Let Scott P. know about this..
Old    Mavy (jovedawake)      Join Date: Mar 2006       07-12-2006, 2:54 PM Reply   
I love it...whenever a Sanger boat has a problem (normally minor), those that don't own a Sanger tend to say something like, "See! Sanger has problems too!!! so HA!".

Yes Sanger boats may have their occasional problems. Actually this can be better stated as everything/everyone has problems.

No one said Sanger was perfect. Just better. HA, just kidding.
Old    Old School (edandgem)      Join Date: Jun 2005       07-12-2006, 3:30 PM Reply   
Hey Ron, I had to change the impeller on my v210 last week at 110 hrs. I was told by my Dealer to Change it every year. the main thing is not to start the boat without water if you do the impeller will burn up very fast. Sorry to see you having problems you are now a Boat owner. LOL
Old    Ken (ghostrider_2)      Join Date: Aug 2004       07-12-2006, 3:32 PM Reply   
I have mine change every winter.
Old    Small Light (stephan)      Join Date: Nov 2002       07-12-2006, 4:50 PM Reply   
Charlie, not one single person said anything about this being a Sanger issue. simmer down nah, simmer down. Besides everyone cuts on everyone else's boat! I'm sure you do it too, welcome to Wakeworld!

We always keep an extra impellar on board just in case. We started doing that because it failed once & we had to Fat Sac pump water into the block, McGyver was so proud!

(Message edited by stephan on July 12, 2006)
Old    Robert Welther (roberto)      Join Date: Aug 2004       07-12-2006, 5:00 PM Reply   
Hey, if you can make it out of any service bay for less than $150, that's a good day! As Ed pointed out, you're now a boat owner.
Old    Mavy (jovedawake)      Join Date: Mar 2006       07-12-2006, 8:18 PM Reply   
stephan,

"Again, no boat is perfect, this stuff happens...even after a few hours. Nothing is perfect....and no manufacturer is immune to having this sort of issue."

He is basically saying Sanger is not perfect. Well thanks for letting me know, I thought mine was...gosh.

I simply thought it was funny. No hard feelings.
Old    Sparky Jay (wake_upppp)      Join Date: Nov 2003       07-12-2006, 8:35 PM Reply   
I suspect this is no "Sanger" problem but rather an "operator" problem. It must of been run "dry" by someone before delivery. It only takes a short run to burn it up. Try and get the old impeller back and post a pic.
Old    walt            07-12-2006, 9:28 PM Reply   
I agree with Sparky. A impeller can fry in seconds if run dry.
Old    Darren Yearsley (ralph)      Join Date: Apr 2002       07-12-2006, 10:36 PM Reply   
What do you mean Sangers not perfect? Nobody told me!

3rd on the run dry theory. 10 seconds can totally shag a dry impeller.
Old    Mavy (jovedawake)      Join Date: Mar 2006       07-13-2006, 7:05 AM Reply   
ralph, you too huh. I have been depressed all last night and this morning...
Old    wakestyle            07-14-2006, 12:19 PM Reply   
stop it.. just stop it... you might jinx my Sanger with all this broken down talk...

Just hit the 90 hr. mark and it's ran totally flawless. I've also never ran my boat dry, and never will. It just makes no sense to me.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 1:59 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us