Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through June 21, 2006

Share 
Reply
 
Thread Tools Display Modes
Old    Jeremy Gentry (hotlanta)      Join Date: Jun 2003       06-08-2006, 9:35 AM Reply   
I've gone back and forth some with Perfect Pass regarding this and apparently there's a new chip that can be installed to help out. BUT...

If there's any weight whatsoever in my 05 X-Star (just factory ballast with 1-2 people) the PP sucks for holding speed accurately.

Has anyone else had success using PP on an X-Star? I'd be particularly interested in success with additional weight (say factory ballasts plus 6 persons).

If so, what KDW and NN settings have proven best?

Thanks!
Old    dhcomp (dhcomp)      Join Date: Jun 2003       06-08-2006, 10:14 AM Reply   
Weight should affect nothing. Only thing it is going to effect is paddle wheel placement relative to where the hull is riding in the water.

Is this one of the boats they had an issue wiht placement on?

Ask your dealer...they may just move the paddle wheel back 6-8"
Old    Eddy Celis (bughunter)      Join Date: Nov 2001       06-08-2006, 11:17 AM Reply   
I had some problems when I first got my 2006. All these were fixed with a new chip and different settings. But I think the 2006 is different from 2005 (throttle-by-wire, new PP).

MCX, factory ballast + 2400lbs.
Old    C.I.E. J-Rod (jarrod)      Join Date: May 2003       06-08-2006, 11:32 AM Reply   
Move the paddle wheel back? What to do with the 2" hole in the bottom of the boat?

Old    Kevin aka Chino (big_xstar)      Join Date: Nov 2004       06-08-2006, 11:45 AM Reply   
jeremy -- we have a 04 X-star and run 2800 lbs of total ballast plus people, and our PP system holds withing .3-.5
We did change the prop which it did seem to help with the speed control and also had adjusted the
KDW and NN. For the life of me I cant remember the setting right now.
Old    Matt (pittsy)      Join Date: Apr 2004       06-08-2006, 11:47 AM Reply   
I had some problems with my 03' X-Star but i haven't had any problems with my new 06' X-Star, i have put about 25hours on it and by far it is much better than the other...in my 03' i had to use the throttle a lot and now i dont need any throttle, even when driving d-ups the PP powers the boat when it needs it..06 xstar, stock ballast, 700lbs in back and 6-7 people..ride at 23.2
Old    Matt (pittsy)      Join Date: Apr 2004       06-08-2006, 12:21 PM Reply   
oh yes...i changed my prop as well..went from stock to a high altitude prop..my PP holds on the number almost all the time unless the water is some what choppy..
Old    Jeremy Gentry (hotlanta)      Join Date: Jun 2003       06-08-2006, 8:16 PM Reply   
Thanks for all the comments. I've gotten the ECM upgrade (adjusts the engine for 05 and beyond since the throttle is electronic) and should have the new chip soon. Between those two it seems I should be all set.

BUT... I'm still hoping someone that's been successful can share their KDW and NN settings????

Thanks.
Old    Michael B (michaelb14)      Join Date: Jul 2001       06-09-2006, 9:42 AM Reply   
KDW - 200
NN - 80
CS - 950

This will hold my speed very well on my 06 with stock ballast and fly high ballast system (boat used at first PWT stop this year).
Old    dhcomp (dhcomp)      Join Date: Jun 2003       06-09-2006, 10:02 AM Reply   
MC definitely had to move some perfect pass paddle wheels. They either repaired the hole, or used the plug you get with your system, not sure....ive never had one that needed to be moved.
Old    Jeremy Gentry (hotlanta)      Join Date: Jun 2003       06-09-2006, 8:17 PM Reply   
CS - 950???

I don't have this option on my 05 perfect pass module... what's CS all about?
Old    Michael B (michaelb14)      Join Date: Jul 2001       06-11-2006, 6:57 PM Reply   
Does your PP do the names?

If so, you do have that optionand just didn't know. ;)

If your CS is to low PP will never get up to speed and if it is to high it will over shoot it. I actually had to read instructions (which I hate doing) to figure out what it was doing. Mine would almost get to the correct speed and it would then slow down.

Default CS was set to 750

Here is a screenshot for the owners manual...
Upload
Old    Shawn K. (shawnk)      Join Date: Jan 2005       06-15-2006, 9:47 AM Reply   
This won't completely fix your problem, but once the cruise is fixed it will be a night and day difference. You need the new OJ prop. You can put all the weight you want and it will run better, better hole shot, more reliable cruise performance, and better fuel economy. Specifically designed for the MCX engine. Just my $.02.

http://www.ojprops.com/site/xmpedge.htm

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:36 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us