Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through May 19, 2006

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (jpshaff01)      Join Date: Jun 2005       05-10-2006, 7:08 PM Reply   
I have at least one leak in my 86 supra comp and its got me weary of running it with any ballast. It looks like its leaking around the drivshaft fitting through the hull and/or the rudder. Its not bad but a couple gallons an hour maybe more which sucks. I think i'm gonna take it to the dealer tomarrow because i'm not sure i trust myself to fix it.

I put some silicone caulk around the areas but it basically got blasted off by the water.

Anybody else deal with this on an older boat. Are there seals that have gone bad?

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 9:03 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us