Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through June 10, 2005

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (parkcityxj)      Join Date: Mar 2001       06-05-2005, 3:49 PM Reply   
So I finally got the carb finally dialed in and she was running the best she ever has until..... Four of us each got a set in and I was pullin up a rider, all of a sudden... Booom and then nothing. Of course I had to get towed in.

Tranny fluid was good and there was no indication what so ever that the tranny was going to go. I can freely spin the prop by hand too

It's a Velvet Drive 1:1. Hopefully I don't need an entire new tranny... Any suggestions before I tear it apart tomorrow?

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 7:56 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us