Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through May 04, 2005

Share 
Reply
 
Thread Tools Display Modes
Old    Dave Garland (dgarland0)      Join Date: Apr 2003       04-24-2005, 6:54 PM Reply   
Question for all of you- Was out on my buddy's boat this weekend and the boat was working perfectly. His prop had a knick in it before, but it got some more damage yesterday afternoon. Before we noticed the new damage the boat idled fine, but when throttled down the boat was lunging or missing. All guages were fine, and when in nuetral engine idled fine. Could a bad prop cause the boat to react this way??? Thanks!

dg
Old    paul (wakeme884)      Join Date: Jul 2004       04-24-2005, 7:37 PM Reply   
with just prop damage "usually" the boat shakes and vibrates due to unbalance. depending on boat type, could be prop shaft? might have even sucked something up off the bottom of the lake.... good luck

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:29 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us