Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through May 04, 2005

Share 
Reply
 
Thread Tools Display Modes
Old    natlchamp2k4            03-31-2005, 9:23 PM Reply   
I have 2 Rockford He2 10's and will be running them on a MA Audio 3600W(@.5 ohm) but the specs say it pushes 400w x 2 RMS at 4ohm. I will run it at 4ohm. Also a 100 x 4 crossfire amp pushing two pairs of 6 1/2 Sony Explods on the tower. Am I going to need to upgrade alternators or add a battery.

P.S. I have all of this stuff around the house (all but the sony's explods) The two subs, both amps etc. all the wires. I think it will sound real good in the boat.
Old    paul (wakeme884)      Join Date: Jul 2004       04-01-2005, 8:23 AM Reply   
Im not running half of what you have and I have 2 batteries. If you use your stereo without the motor running at all, run 2 batteries. For peace of mind, just in case. Nothing worse to be stranded on the water with a dead battery. And its a bit difficult to push start a boat.....

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:32 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us