Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through August 27, 2003

Share 
Reply
 
Thread Tools Display Modes
Old    juice            07-21-2003, 8:21 AM Reply   
My X10 ballast will not empty. It fills but will not empty anybody have any tips
Old    bambamski            07-22-2003, 6:50 AM Reply   
My Front pump did that and it had to be replaced. All of them won't empty? Try adjusting the valves that let the water in and out.
Old    debsxstar            07-22-2003, 7:14 AM Reply   
I have had trouble with my center locker ballast not emptying. it turns out the plastic bag was folding up on to itself and blocking the valve then the pump was getting hot then it would shut down. Is it one of the hard tanks that is not emptying?
Old    juice            07-22-2003, 1:11 PM Reply   
It's all the tanks and my center one is hot. Where are the valves that let the water in and out?
Old    bambamski            07-22-2003, 3:31 PM Reply   
They are black and red and I believe they are under the engine, however I'm not completely sure where the location is, all I know is that mine cracked because the guy that winterized my boat didn't do it properly. Try checking the valve switches that are in the engine compartment on the drivers side at the very back. They say open and closed, I find they actually work better when they are half way between the open closed positions. Hope this helps.
Old    debsxstar            07-22-2003, 5:31 PM Reply   
My boat is an 02 xstar and the center locker ballast has a valve towards the rear of the bag (the portion of the bag closest to the back of the boat. I would just pull on the other end of the bag and stretch it out and way from the value a little. Then turn on the switch and see if it works. If all of the tanks aren't emptying? Geez....I wonder if they are all working off of one pump? hmmmmm
Old    x10            07-22-2003, 9:51 PM Reply   
Do you have an 01 or 02 X10? There are very different systems in each boat
Old    juice            07-24-2003, 7:28 AM Reply   
'02 X10
Old    x10            07-25-2003, 9:38 PM Reply   
I would bet the that impellrr is sticking in the fill position and when you go to empty and the motor overheats and shuts off. Before you begin to empty run the pump in the fill position first and then switch to empty(reverse direction). Another solution is to run the pump on empty briefly after filling so it is positioned to run in the correct direction when you start to empty. Either of these techniques will likely work. There is a factory warranty replacement impellor that has less friction and will give you less trouble with the pump overheating.
Old    aircanada            07-27-2003, 7:37 PM Reply   
Could also be a thrown breaker.

Check that the light on the switch is turning on when you flip it and that you can hear the pumps running. If not, you will likely need to reset your breaker. There are three little nipples located just below the ballast switches (one nipple per switch), press the nipple corresponding to the tank that will not empty and it will (should) reset the breaker.

heheh I said nipple!
Old    sonicr1            07-27-2003, 9:48 PM Reply   
I had issues with our pumps when we fist got the boat... rocking them as TomV says works... but the fix is to replace the impellers... They are free recall parts from your dealer. Once I replaced the impellers, I haven't had any problems.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 9:55 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us