Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (wkbrdr1989)      Join Date: May 2013       07-06-2014, 9:13 AM Reply   
I have a 2006 malibu wakesetter with the 383 hammerhead engine. Over the past year we have started having a problem when trying to get on plain. It doesnt happen all the time but every now and then when we go to pull or just get the boat up n go it will get to around 25, start popping and we have to back off the throttle. Sometimes it will let us back off to around 20 and it will run but you can hear it sounding like its getting the fuel in spirts. A trick we have done in the past to fix it is take the fuel filter off under the back seat, blow out any gas in it and then put it back on and it would be good for a hour or so but this summer its gotten worse. We have replaced the filter under the seat, replaced the fuel regulator but still, same issue. Does anyone know what is causing this? Our next step is the fuel pump but before we spend 500 dollars we want to make sure that is what is causing it. Any help would be great, thanks!

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 3:54 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us