Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (dp513)      Join Date: Jul 2011       04-11-2014, 8:27 AM Reply   
Hey guys. So yesterday out on the water I noticed I had high oil pressure and my engine temp was close to 200. I stopped and oil pressure and engine temp dropped. I checked the oil after a minute and it was way high. Like an inch past full. Oil is clean as it was just changed by previous owners mechanic. What my question is. Is could too much oil raise your engine temp. I'm gonna suck some out after work get it to normal levels and then go test it. Another thing to keep in mind is that no alarm sounded and it didn't go into guardian mode.

Another odd thing. My front ballast fills fine. But when I go to drain it will pop the breaker. Any ideas on that?

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:45 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us