Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (Paulvette01)      Join Date: Apr 2013       11-01-2013, 3:02 AM Reply   
finally bought an X-Star, 2009 - previous boat was a 1998 Maristar 225VRS.

the Maristar wake unballasted was pretty good, the X-Star wake is way better but heres the problem (and probably lack of knowledge and experience on my part as only had the boat a few weeks). if we ride without ballast at around 22.5 / 23mph the passenger side wake is washed out and the boat seems a bit tilted on the drivers side but this didn't happen with the Maristar. We are in the same lake which is mostly only around 6 to 9ft deep, i can clean it up with ballast in the port side but should i need to? anyone have a rough guide to where to best ballast the boat in our shallow lake (p.s. i have put in ballast and the wake is awesome, more than pleased with it). I think the ballast pumps are also on factory preset 2mins runtime which isn't enough to fill the tanks but i'll time them this weekend.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:58 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us