Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (WakeNauty_08)      Join Date: Sep 2012       09-12-2013, 8:49 AM Reply   
Hey guys, Hoping you can help me out. One of my speakers has come loose from its clamp and I do not know how to tighten it back up. I feel silly asking but do not want tear anything up if i go about it wrong. They are on my 2013 Nautique 230, Its the new tower if that helps identify the clamps in anyway. I have taken off the speaker grill and the light ring an found that the LED strips are glued in front of the speaker and also the speaker is glued in.

Any advice on how to go about it? I hope i don't have pull out the LED strips and pry that speaker out.

Side note, The clamp is securely tightened to the tower. Its the speaker to its clamp.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 7:53 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us