Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Larry Kaub (campertime1)      Join Date: Aug 2013       08-30-2013, 10:36 AM Reply   
I have a 2012 epic 23v.........it was briefly underwater and i purchased the boat....i am not getting power to the dash or back to the starter........all of my switches are working and stereo etc.........any info would help!
Old    RB (boardman74)      Join Date: Jul 2012       08-30-2013, 11:20 AM Reply   
I hope you got a smoking deals. Submerged vehicle very often have electrical problems for the rest of their days. Start from the battery and work forward. A wiring diagram will be your friend.
Old    Joe Sellhausen (joesell)      Join Date: Apr 2001       08-30-2013, 2:17 PM Reply   
There's a circuit breaker on top of the engine near the front (back of boat). Make sure it's not popped. There's also a fusible link on the starter. It's the little white block on the starter that the wires are hooked up to. Disconnect the wires and check for continuity. If that blows, it'll give you the symptoms your describing.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 3:31 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us