Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (beleza)      Join Date: Mar 2010       07-31-2013, 2:33 PM Reply   
So... I just picked up a new to me 04 Super Air TE. Love it. I took it out for the first time today and turned on the ballast but nothing was pumping into the tanks. Pumps were going but no water was coming in. When I got home I looked under the dash and saw the ballast valves were all on CLOSED. I went to turn them to OPEN but they wouldn't budge. The port valve was the only one I could turn. I didn't want to turn too hard because I didn't want to break anything. Is there a trick to turn the valves to the OPEN position? I plan on taking the boat out tomorrow so any help is appreciated.
Attached Images
 

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:31 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us