Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    SS (illini88)      Join Date: Oct 2007       06-09-2013, 2:49 PM Reply   
So I went to drop my boat in for the first time this year. We are way late, but the lake was closed the previous two weekends due to flooding. As I always do to start the year, I let it run for a min on the trailer backed into the water just to make sure everything is ok. I could smell that something was hot, so I shut her down. I touched the manifold and it was fairly warm, so I pulled out the plug in the manifold. Bone dry. Pulled the boat out of the water and started taking out the water pump. What I found when I got the pump out was not good. There were two big cracks in the housing. When I took apart the housing, the impeller was toast I went back and fished out chunks of the impeller in the trans line and the line leading to the water pump itself. My concern is, what caused the cracked pump. I mainly ask because I'm in a cold climate. I always run antifreeze through the boat and then drain. While I feel iwould have noticed no antifreeze draining out of the manifold, block, etc, when I was winterizing, it's been since October, so I'm a little jumpy. My assumption is that I got the impeller dry while doing this. That being said, I worry that the cracking in the housing could have been from water sitting there all winter. Any thoughts? Could I fry the housing from the impeller running dry?

For what it's worth, the boat is an 01 Elite V.
Old    Robert Stone (robertstone9)      Join Date: Sep 2011       06-09-2013, 3:00 PM Reply   
how cold was your winter?
Old    Charlie Zulu (Pad1Tai)      Join Date: Jan 2013       06-09-2013, 3:32 PM Reply   
Is it a plastic housing pump or bronze housing pump?
Old    SS (illini88)      Join Date: Oct 2007       06-09-2013, 4:55 PM Reply   
Plastic. I'm in Illinois. It was a warmer than usual winter, but it's still plenty cold to freeze.
Old    Chris Dirty (Dmac420sj)      Join Date: Mar 2012       06-09-2013, 7:32 PM Reply   
Happens all the time. No worries replace it and get on the water!
Old    SS (illini88)      Join Date: Oct 2007       06-10-2013, 11:17 AM Reply   
So I took a few deep breaths and am feeling better about it. It's just been a long time since October. I know I had antifreeze coming out the exhaust when I was winterizing, so I'm feeling a little better. Just have never seen a part fail quite like that housing did. I'll order a new housing tonight.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:49 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us