Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (jonblarc7)      Join Date: Jul 2006       06-04-2013, 9:28 AM Reply   
I'm finally getting around to redoing my stock supra system but on a budget.

What I have now-

Amp Kenwood KAC-8402

Sub Kenwood Excelon KFC-xw12 (doesn't have a box yet you'll have to ask supra why)

Inboats 6 factory Kenwood 6.5

Tower Roswell sound bar (sold)

Now REV-10's

My plan is to add perko (boat doesn't have one) and already have a group 27 to go in the boat with the starting battery might even add a second group 27 but I don't float with it blaring for long periods of time so I'm not sure if I even need a second.


New amps

PPI 900.4 to run the REV 10's

PPI P1000.1 to run the sub

Keep the KAC-8402 to run the six inboats.


I'm guessing I'll run 1 gauge to a distro block and then 4 gauge to the amps.

See any problems or have better budgeted idea's or any thing I need to look out for when wiring up the amps.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:09 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us