Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (dnell)      Join Date: Oct 2011       05-16-2013, 9:42 AM Reply   
Need some ideas here. Any will be good. So I have a 2013 MB F21 Tomcat. It has the Indmar 410 in it and I have a Acme 2079 high altitude prop on it. Up until this last weekend it has been a true power house. We ride full ballast 1800lbs and 600-650 lbs in the nose. Around 3-8 adults at any given time. This last weekend we had 5 adults all between 120-200 lbs and 2 kids 60lbs max. The boat has never had a single issue getting on plane. Most the time I don't even use the cav plate. Well the boat has no power now. Takes forever to get on plane even with the plate down. It honestly feels like someone swapped engines and prop on me. So of course it is under warrantee but I'm just confused???? Just wondering if anyone has had this happen to them or has any ideas at all on the loss of power. The dealer hooked up there computer and said there was no errors. Water test tonight (may 16)... Thanks for any info.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 5:28 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us