Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (CTXxRoss)      Join Date: Apr 2013       05-03-2013, 3:20 PM Reply   
Ok so I bought a 2000 Moomba Kamberra. The guy never washed or waxed the boat from what I can tell and it had a ton of hard water stains down the side at the water line. I used Meguiars #67 compound to remove the stains and it left the boat hazy in some areas, I went back with some Mothers Carbanua Wax and it left the boat a hazy white where I waxed it!! Is the gel coat trashed or did I do something wrong. I used a multiple speed orbital buffer to compound and just a towel to wax on and off. Any help would be great!!

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:57 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us