Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (ettowake)      Join Date: Oct 2009       12-21-2012, 2:42 PM Reply   
Whats upppp
My 315horsepower mercruiser is very strong and good til now
but just now with 705Hours an 1,5 year of using it begin to
when in full throtle all the way it lacks fuel in the engine and backs to idle without moving the throtle positionn.. but when not all the way down it goes normally.. my first thought was the Fuel water separator and filter, changed and keeps doing the same thing.. can it be the Fuel Pump doing this? just when the engine really needs the gas it dont work? assuming there are 2 fuel pumps one that without it the engine will not start, and the other for the high end rpms?
apreciate for any help.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 7:44 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us