Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (ottog1979)      Join Date: Apr 2007       09-24-2012, 12:07 PM Reply   
I'm having alternator issues and electrical is my worst DYI subject. A little over 2 years ago, my alternator stopped working and I had it replaced. Stock alternator for Mercruiser 350 Mag MPI. Just this last week, the same issues are coming up again and the alternator is dying/died. Volt meter goes slowly from 13 down to 10, then 9, then 8 volts and things on the boat stop working simultaneously, then at all. This happens over a day or two (not all at once). Boat will run but when you turn on a ballast or bilge pump, the Perfect Pass will turn off (not enough juice to run everything). Obviously, I need a new one.

But why such a short life? Will a heavier duty alternator fix this issue? There's nothing that unusual on my boat as far as electrical accessories: 2 amplifier stereo, Perfect Pass, basic bilge & ballast pumps. That's it. Could it just be that I need a beefier alternator or should I be checking out other potential issues?

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:05 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us