Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    BLAIR BARHAM (jonblarc7)      Join Date: Jul 2006       08-27-2012, 7:25 AM Reply   
Anybody know know the part number for the raw water pick impeller for a Indmar assault 325. I had my engine over heat yesterday and go into limp mode on my 06 24v supra. So I'm asuming its the impeller.
Old    Boarder 42 (jhartt3)      Join Date: Jan 2012       08-27-2012, 7:43 AM Reply   
http://www.skidim.com/

Contact these guys they are very knowledgeable. And can get you what you need. Good pricing too.
Old    BLAIR BARHAM (jonblarc7)      Join Date: Jul 2006       08-27-2012, 8:32 AM Reply   
Can't I just go pick it up at Napa so I don't have to wait for it to ship?
Old    Jeff Hill (hillbilly)      Join Date: Aug 2002       08-27-2012, 9:44 AM Reply   
09-812B1 Johnson is what I put in my 07 Moomba with that engine.
Old    BLAIR BARHAM (jonblarc7)      Join Date: Jul 2006       08-27-2012, 9:50 AM Reply   
Thanks Jeff
Old    Jeff Hill (hillbilly)      Join Date: Aug 2002       08-27-2012, 10:05 AM Reply   
I picked mine up from Westmarine......if you have one close by.
I think it was around $30?
Old    BLAIR BARHAM (jonblarc7)      Join Date: Jul 2006       08-27-2012, 12:04 PM Reply   
I just gave napa the 09-812b1 number and they had it for $40. That was about the only choice that was local, now I can have it replaced tonight with only one day of down time.

Thanks guys
Old    Jeff Hill (hillbilly)      Join Date: Aug 2002       08-27-2012, 12:23 PM Reply   
Make sure and check your hoses for impeller chunks!!
I found quite a few in the line just below my tranny filter/cooler.
Old    BLAIR BARHAM (jonblarc7)      Join Date: Jul 2006       08-27-2012, 12:24 PM Reply   
will do!!!
Old    Trenton Allman (TrentAllman1)      Join Date: Aug 2012       08-27-2012, 8:09 PM Reply   
You need to look at the pump housing real good, I put an impeller in this summer and it only lasted an hour on a 97 Tige with a Mercruiser engine. I have no idea what you have, but if it is a plastic housing replace both as it is only a few dollars more to get both in my case. I would order a spare to keep for next time too.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:34 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us