Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (bac)      Join Date: Feb 2008       06-04-2012, 5:33 PM Reply   
Hey yall, lookin for some help on a problem

Workin on a 00 wakesetter thats been sittin for the last 2 years. Small block chevy indmar.

Raw water pump shaft bearing was shot, after some quick researching, saw it was best to just replace the entire unit vs. rebuilding. Removed the bolts from the bracket and base where it sits on top of the pulley and went to knock it off, which is where the problem starts. The housing knocked loose but the shaft stayed on the pulley. The boat is used in brackish water 95% of the time and the base is nicely rusted. Any ideas for getting this off the pulley? Is there something I've missed? Soaked it in solvents but no luck yet. Thanks in advance

Heres a pic, sorry for the bad lighting, boat is in a corner of the shop and kinda dim
Attached Images
 

Last edited by bac; 06-04-2012 at 5:36 PM.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 8:17 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us