Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (worththewake)      Join Date: Nov 2006       06-02-2012, 10:10 AM Reply   
So the story continues....I have noticed that the truck as been running a little sluggish lately and then last night on my drive out of town I was forced to slow down considerably and when I went to get back onto it the truck had no get up and go and the pedal was on the floor. I looked back in the rear view mirror and all I saw was white smoke pouring out of the exhaust. I then backed off of it and it was fine. I called the dealership today and naturally they want to see it and their initial explanation is either oil or blown injector. Any other thoughts? It has close to 60,000 on it.....
Chris

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 1:32 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us