Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (sawyer1206)      Join Date: Apr 2012       06-01-2012, 7:51 PM Reply   
I had a local mechanic install a flush kit on my PCM Excalibur 330 and I picked it up today. When he was showing me where he installed the flush kit he told me that I need to start the engine then turn on the water. He said it would take two people because you would need to turn on the water right after you start the engine. I asked why, since this goes against everything I know about inboard motors. He said that if I turn on the water without the engine running I would risk blowing out hte oring on the impeller housing. Is this right??

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:10 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us