Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Wakeboarding Discussion

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (OldDog)      Join Date: Oct 2011       05-29-2012, 3:42 PM Reply   
First runs of the season were great until!!!!! I was doing a slide when I cought the front of the board and did a face plant(an easy 8.5 thank you) when I came out of the coma I had one boot off and one on and the board was floating. The boot that was still on had a busted strap buckle and the one that was on actually ripped right off the board. Is this normal? defect? or has this happened to anyone? And on a side note I am starting to get the feeling back in my feet
Attached Images
 

Last edited by OldDog; 05-29-2012 at 3:47 PM.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 8:05 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us