Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Wakeboarding Discussion

Share 
Reply
 
Thread Tools Display Modes
Old    Adam Van Dyke (lfadam)      Join Date: Nov 2008       10-05-2011, 12:12 PM Reply   
I bought a pair of Launch Pad 540s and a Tsunami pump recently. I got the adapter that goes to the waterbed kind of fittings, knowing that Fly High (Tsunami) uses a different system than Launch Pad. All of my Launch Pad sacks have had the waterbed fittings as well as their Quick Connect, so I assumed my adapter would get the job done. Unfortunately the new Launch Pad sacs appear to have 3 Quick Connect fittings each and 0 waterbed fittings. Very aggravating. I can make it work to fill, but I would have no way of draining the sacs. I just went on buywake to try to find the correct adapter, but it didnt look like they made a Tsunami Pump to Launch Pad quick connect adapter. Anyone know where to find one? If not, how can I make this adapter work? http://www.buywake.com/catalog/detail/2109300 Do I need a 2nd adapter? (I have to be able to switch between waterbed and Quick connect because we have another sac that is waterbed fitting only)

Thanks

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:46 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us