Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Parker Frost (waketowake)      Join Date: Jul 2007       06-27-2011, 9:23 AM Reply   
So i took my 07 x star in because the speedometer wasn't reading speed. This also means my PP is out . I took it in, and they replaced the paddle wheel. (They told me that was the problem) picked it up and still didn't work. Any ideas!?
Old    Jeremy (wake77)      Join Date: Jan 2009       06-27-2011, 9:29 AM Reply   
Are you able to get anything in the RPM mode?
Old    Parker Frost (waketowake)      Join Date: Jul 2007       06-27-2011, 9:37 AM Reply   
its show rpm but it wont set at them.
Old    Jeremy (wake77)      Join Date: Jan 2009       06-27-2011, 12:11 PM Reply   
I would call PP customer service and see if they have any advice.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:18 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us