Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Chase Tillett (tn_rider)      Join Date: Dec 2009       04-25-2011, 2:39 PM Reply   
sunday i was out chilling before a set and noticed while i was in idle the engine temp jumped up hot! but then went back down. i sat there for a second and it never went back uo. i let the boat rev at 2500 rpm for a couple minutes. it jumped up one more time but never got hot again. also i noticed what looked like smoke coming out of the exhaust, but smelled like the normal emissions that come out. is this just cause my boat is just getting the cob webs out from being set up all winter? or do i have a problem? thanks for any help!
Old    Mike (ponyh8r)      Join Date: Dec 2004       04-25-2011, 3:24 PM Reply   
Quote:
Originally Posted by tn_rider View Post
sunday i was out chilling before a set and noticed while i was in idle the engine temp jumped up hot! but then went back down. i sat there for a second and it never went back uo. i let the boat rev at 2500 rpm for a couple minutes. it jumped up one more time but never got hot again. also i noticed what looked like smoke coming out of the exhaust, but smelled like the normal emissions that come out. is this just cause my boat is just getting the cob webs out from being set up all winter? or do i have a problem? thanks for any help!
It sounds like you need a new impeller. The impeller is likely missing veins and when the boat is at idle it is unable to sufficently cool it.
Old    Baitkiller (baitkiller)      Join Date: Jan 2010       04-25-2011, 6:04 PM Reply   
^^^^^^^^^^^^^^^^^^
X2

The white smoke is steam.
Old    Chase Tillett (tn_rider)      Join Date: Dec 2009       04-25-2011, 7:13 PM Reply   
if the white smoke is steam, could it be the gasket in my exhaust manifold leaking? i dont get how while running faster than idle and temps are fine, that it could be the impeller. thanks for the help
Old    Clint (ttuclint)      Join Date: Sep 2003       04-26-2011, 7:44 AM Reply   
impeller
Old    WakePowell Chris (epic1)      Join Date: Oct 2006       04-26-2011, 9:12 AM Reply   
when running faster than idle, the impeller is turning faster. If the impeller is indeed missing teeth, than the faster revoultions at higher rpm will absoutly help cool it more. Listen the the gurus.
They answered your question.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:17 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us