Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (mattgettel)      Join Date: Jan 2009       02-04-2011, 5:11 AM Reply   
I have a 1990 Supra Sunsport. I have had no trouble out of this boat yet and have owned it for about 2 years now. I took it out one last time in the fall and the oil light came on. I immediately turned the boat off and checked my oil. The oil is at the right amount. I then took the boat back to the dock. As soon as I come above idle it quits making the noise. The boat has about 350 hours on it. I know there are several things it could be but I am just wondering if anyone has ran into this before and found a solution. Thanks guys.

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 7:25 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us