Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (bzubke1)      Join Date: Feb 2010       01-19-2011, 7:40 PM Reply   
Our first boat was 1976 Forester Tri-hull with a Chrysler 75 outboard. We blew the engine the first time out because the impeller was bad and we didn't realize it. We sank the engine and back end once when we were gone for a weekend and it filled up with water, dried it out and it worked fine. We sold it when we got the new boat and ended up seeing it along the highway and i had to snap these pics.
Our current boat is a 2008 Mobius LSV, its a lot different from the old boat but I definatley loved that old thing when we had it.


 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 2:34 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us