Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Trick Tips

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (t0nyv831)      Join Date: Jun 2008       08-26-2010, 6:30 PM Reply   
Ok, so I've been trying these both out in the flats and off the startup roller (inside out). The closest I've gotten was out in the flats (actually landed, but got excited and then caught my edge). Since then, I haven't been able to land any!! Inside out it feels like the rope is pulling me off axis everytime and I get worked. I am slowing the boat down to about 19mph, but even then the side of my head takes a beating when trying these. Not sure how to correct this (the getting off axis part). Any pointers/helpful hints appreciated. BTW, I can ride relatively comfy cuffed (both hands) on the side where I'm trying to land the HS BS 1.

Thanks,

Tony

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:50 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us