Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (tn_rider)      Join Date: Dec 2009       08-13-2010, 9:20 PM Reply   
just pulled the trigger on a 2003 malibu wakesetter VLX and the perfect pass is giving me some trouble! when i turn on the perfect pass and take off it will get up to speed but is slow getting up to speed..the boats speed is fine but the digital mph on the perfect pass is slow. it gets up to speed and beeps and has the lines under the mph like its supposed to but its like it doesnt catch the speed or something, any help would be amazing!!....the only other thing is the gas gauge isnt working properly, any info on that would be helpful as well!! thanks so much

chase

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 1:54 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us