Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Non-Wakeboarding Discussion

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (jarrod)      Join Date: May 2003       08-09-2010, 12:44 PM Reply   
After 15 years of riding street bikes, I took my first slide across the blacktop Friday at 50-60 mph. Shouldn't have happened. I believe the overly soft front suspension was to blame for the front wheel washing out, because the bike was no where near it's limit.

Anyway....full gear (like always) I slid for about 40-50 feet, stood up, laughed, and kept riding. The recently installed frame slider saved the bike. The recently installed exhaust is history!

I shared a few pics below.
Attached Images
   

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 5:19 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us