Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old     (wakejunki3)      Join Date: Aug 2010       08-08-2010, 1:23 PM Reply   
Hi All,

To end an almost perfect day at the lake, my wife forgot to kill the boat engine after driving onto the trailer. I noticed it was still running when I got out of my truck to wipe down the boat (~ 1 minute). The engine temperature was fine and no alarm was going off. I quickly jumped in the boat and turned it off.

This morning, I pulled off the raw water pump and inspected the impeller, which looked good. Actually the impeller was still a wet when I pulled it out.

Other than checking the impeller, are they any other concerns I should be aware of?

Thanks!
Old    James (Silverbullet555)      Join Date: May 2010       08-08-2010, 1:27 PM Reply   
I think you will be fine. I would replace the impeller just to be sure it doesn't fail at a bad time. Other than that, you should be good. imho.
Old     (wakejunki3)      Join Date: Aug 2010       08-08-2010, 1:29 PM Reply   
@James - Thanks for the reply....yeah I swamped it with a new one when I inspected and kept the old (which still looks good) as a backup.
Old    KEVIN (kko13)      Join Date: Jul 2006       08-08-2010, 5:56 PM Reply   
Been there wife did that 2 me 2. If impeller is ok your golden........it was the guy that didnt notice until after 30 minutes into is ride home that had issues.
Old    Dave Kiehl (dave27)      Join Date: May 2005       08-09-2010, 8:26 AM Reply   
You're money, I wouldn't worry at all.
Old     (wakejunki3)      Join Date: Aug 2010       08-09-2010, 8:46 AM Reply   
Cool...I was so scared when it first happened....it took all my might not to tear my wife a new one...but I know she didn't mean to do it :-)
Old    Richard Coop (mendo247)      Join Date: Mar 2005       08-09-2010, 9:02 AM Reply   
Happened to me once also a few years back after a long weekend. Never even changed my impeller.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:16 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us