Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old     (wakejunki3)      Join Date: Aug 2010       08-08-2010, 1:23 PM Reply   
Hi All,

To end an almost perfect day at the lake, my wife forgot to kill the boat engine after driving onto the trailer. I noticed it was still running when I got out of my truck to wipe down the boat (~ 1 minute). The engine temperature was fine and no alarm was going off. I quickly jumped in the boat and turned it off.

This morning, I pulled off the raw water pump and inspected the impeller, which looked good. Actually the impeller was still a wet when I pulled it out.

Other than checking the impeller, are they any other concerns I should be aware of?

Thanks!

 
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:12 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us